読者です 読者をやめる 読者になる 読者になる

【Vagrant】psqlコマンドでエラー(WARNING: psql version 8.4, server version 9.5.)

 

psqlコマンド実行時に以下のエラー
WARNING: psql version 8.4, server version 9.5.

※9.5を入れているのに、8.4を見にいっているためです

 

<対策>

8.4 /usr/bin/psql

9.5 /usr/pgsql-9.5/bin/psql


バックアップしておく
sudo mv /usr/bin/psql /usr/bin/psql.bk

 

シンボリックリンクを張る(ターゲットのパス リンクのパス)

sudo ln -s /usr/pgsql-9.5/bin/psql /usr/bin/psql